Dismiss Notice
JOIN IGOTASLINGSHOT.COM TODAY!

100% free registration for all Polaris Slingshot enthusiasts. Businesses welcome to promote for (FREE) too.

Stalls After Starting

SlingRider Aug 24, 2017

Tags:
  1. SlingRider

    SlingRider Active Member

    139
    123
    43
    OK, so I know you have to pay to play, but this issue is something that has to be fixed or someone else has had to have it. I have a 2017 Polaris Slingshot SLR and I'm really getting frustrated as I have so much money in this Slingshot. I do have an Alpha Turbo Kit on it which has a 3rd to 4th stutter, but that is a different issue altogether and for another post, but when the Slingshot has been sitting and I go to start it up it dies.

    Any idea why it dies once I start it? I then start it back up and it's good to go.

    Please let me know if you had this issue and what it took to fix it and my dealer has no clue.

    Thank you,
    SlingRider
     
    IGOTASLINGSHOT likes this.
  2. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    227
    116
    43
    We will share this to our Facebook page and hope someone can help you.

    Sorry about your issues friend.
     
    SlingRider likes this.
  3. SlingRider

    SlingRider Active Member

    139
    123
    43
    Well we found the issue as of why it was stuttering when shifting from 3rd to 4th gear. I will make a new thread.

    I was told this is normal for Alpha Powersport when running a turbo.
     
    IGOTASLINGSHOT likes this.